AppleWorks 6 and Peak 4 will not work in Apple Lion

Well that’s a drag. πŸ™
I just found out that in addition to Quicken 2005, AppleWorks 6 and Peak 4 are dead in Lion. Might have to keep that ol G5 around after all.

Leave a Reply

Your email address will not be published. Required fields are marked *